PS Suite Ocean Custom Form 2.90 Release Notes

The v2.90 release of the PS Suite custom form addresses issues with checkout and concurrent access to charts containing the Ocean custom form. It also provides better visibility into the delivery of secure messages to patients (a new feature in beta).

If you are running 2.84 or 2.87, you should upgrade to 2.90 immediately. If you are on v2.72 and PS Suite 5.3 ("Fox"), we recommend that you hold off on upgrading for a week or two as this is a stable combination.

See the following article for more background on PS Suite integration guidance for sites on various versions of PS Suite, particularly advanced access versions:

https://cognisantmd.zendesk.com/hc/en-us/articles/213808428-Ocean-Compatibility-for-PS-Suite-5-4-Advanced-Access-PS-Suite-

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request